What’s Vulnerable › Vulnerabilities
CVE-2023-23356: QuFirewall
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-19 · updated 2026-06-17
- Weakness: CWE-77
Description
A command injection vulnerability has been reported to affect several QNAP operating system versions. If exploited, the vulnerability could allow remote attackers who have gained administrator access to execute arbitrary commands. We have already fixed the vulnerability in the following versions: QuFirewall 2.3.3 ( 2023/03/27 ) and later and later
Affected products
- QNAP Systems Inc. QuFirewall: before 2.3.3 — fixed in 2.3.3
How to fix
Upgrade to a fixed version: QNAP Systems Inc. QuFirewall 2.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-23356 or the next vulnerability affects your stack