What’s Vulnerable › Vulnerabilities
CVE-2023-23363: QTS
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-22 · updated 2026-06-17
- Weakness: CWE-120
Description
A buffer copy without checking size of input vulnerability has been reported to affect QNAP operating system. If exploited, the vulnerability possibly allows remote users to execute code via unspecified vectors. We have already fixed the vulnerability in the following versions: QTS 4.3.6.2441 build 20230621 and later QTS 4.3.3.2420 build 20230621 and later QTS 4.2.6 build 20230621 and later QTS 4.3.4.2451 build 20230621 and later
Affected products
- QNAP QTS: from 4.3.3 before 4.3.3.2420; from 4.3.4 before 4.3.4.245; from 4.3.6 before 4.3.6.2441 — fixed in 4.3.3.2420, 4.3.4.245, 4.3.6.2441
How to fix
Upgrade to a fixed version: QNAP QTS 4.3.3.2420, 4.3.4.245, 4.3.6.2441. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-23-25
- https://www.qnap.com/en/security-advisory/qsa-23-25
Get alerted when CVE-2023-23363 or the next vulnerability affects your stack