What’s Vulnerable › Vulnerabilities
CVE-2023-23488
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 92.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-20 · updated 2026-06-17
- Weakness: CWE-89
Description
The Paid Memberships Pro WordPress Plugin, version < 2.9.8, is affected by an unauthenticated SQL injection vulnerability in the 'code' parameter of the '/pmpro/v1/order' REST route.
Affected products
- Paid Memberships Pro: before 2.9.8 — fixed in 2.9.8
How to fix
Upgrade to a fixed version: Paid Memberships Pro 2.9.8. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/171661/WordPress-Paid-Memberships-Pro-2.9.8-SQL-Injection.html
- https://www.tenable.com/security/research/tra-2023-2
- http://packetstormsecurity.com/files/171661/WordPress-Paid-Memberships-Pro-2.9.8-SQL-Injection.html
- https://www.tenable.com/security/research/tra-2023-2
Get alerted when CVE-2023-23488 or the next vulnerability affects your stack