What’s Vulnerable › Vulnerabilities
CVE-2023-23551: X-600M Code Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-13 · updated 2026-06-17
- Weakness: CWE-94
Description
Control By Web X-600M devices run Lua scripts and are vulnerable to code injection, which could allow an attacker to remotely execute arbitrary code.
Affected products
- Control By Web X-600M devices: before 1.16.00 — fixed in 1.16.00
How to fix
Upgrade to a fixed version: Control By Web X-600M devices 1.16.00. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-23-040-01
- https://www.cisa.gov/uscert/ics/advisories/icsa-23-040-01
Get alerted when CVE-2023-23551 or the next vulnerability affects your stack