What’s Vulnerable › Vulnerabilities
CVE-2023-23554
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-07 · updated 2026-06-17
- Weakness: CWE-427
Description
Uncontrolled search path element vulnerability exists in pg_ivm versions prior to 1.5.1. When refreshing an IMMV, pg_ivm executes functions without specifying schema names. Under certain conditions, pg_ivm may be tricked to execute unexpected functions from other schemas with the IMMV owner's privilege. If this vulnerability is exploited, an unexpected function provided by an attacker may be executed with the privilege of the materialized view owner.
Affected products
- IVM Development Group pg_ivm: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: IVM Development Group pg_ivm 1.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/sraoss/pg_ivm
- https://github.com/sraoss/pg_ivm/releases/tag/v1.5.1
- https://jvn.jp/en/jp/JVN19872280/
- https://github.com/sraoss/pg_ivm
- https://github.com/sraoss/pg_ivm/releases/tag/v1.5.1
- https://jvn.jp/en/jp/JVN19872280/
Get alerted when CVE-2023-23554 or the next vulnerability affects your stack