What’s Vulnerable › Vulnerabilities
CVE-2023-23612: Issue with whitespace in JWT roles in OpenSearch
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-26 · updated 2026-06-17
- Weakness: CWE-287
Description
OpenSearch is an open source distributed and RESTful search engine. OpenSearch uses JWTs to store role claims obtained from the Identity Provider (IdP) when the authentication backend is SAML or OpenID Connect. There is an issue in how those claims are processed from the JWTs where the leading and trailing whitespace is trimmed, allowing users to potentially claim roles they are not assigned to if any role matches the whitespace-stripped version of the roles they are a member of. This issue is only present for authenticated users, and it requires either the existence of roles that match, not considering leading/trailing whitespace, or the ability for users to create said matching roles. In addition, the Identity Provider must allow leading and trailing spaces in role names. OpenSearch 1.0.0-1.3.7 and 2.0.0-2.4.1 are affected. Users are advised to upgrade to OpenSearch 1.3.8 or 2.5.0. There are no known workarounds for this issue.
Affected products
- AWS Opensearch: from 1.0.0 before 1.3.8; from 2.0.0 before 2.5.0 — fixed in 1.3.8, 2.5.0
How to fix
Upgrade to a fixed version: AWS Opensearch 1.3.8, 2.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/opensearch-project/OpenSearch/releases/tag/2.5.0
- https://github.com/opensearch-project/security/security/advisories/GHSA-864v-6qj7-62qj
- https://github.com/opensearch-project/OpenSearch/releases/tag/2.5.0
- https://github.com/opensearch-project/security/security/advisories/GHSA-864v-6qj7-62qj
Get alerted when CVE-2023-23612 or the next vulnerability affects your stack