What’s Vulnerable › Vulnerabilities
CVE-2023-23613: Field-level security issue with .keyword fields in OpenSearch
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-26 · updated 2026-06-17
- Weakness: CWE-200
Description
OpenSearch is an open source distributed and RESTful search engine. In affected versions there is an issue in the implementation of field-level security (FLS) and field masking where rules written to explicitly exclude fields are not correctly applied for certain queries that rely on their auto-generated .keyword fields. This issue is only present for authenticated users with read access to the indexes containing the restricted fields. This may expose data which may otherwise not be accessible to the user. OpenSearch 1.0.0-1.3.7 and 2.0.0-2.4.1 are affected. Users are advised to upgrade to OpenSearch 1.3.8 or 2.5.0. Users unable to upgrade may write explicit exclusion rules as a workaround. Policies authored in this way are not subject to this issue.
Affected products
- AWS Opensearch: from 1.0.0 before 1.3.8; from 2.0.0 before 2.5.0 — fixed in 1.3.8, 2.5.0
How to fix
Upgrade to a fixed version: AWS Opensearch 1.3.8, 2.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/opensearch-project/OpenSearch/releases/tag/2.5.0
- https://github.com/opensearch-project/security/security/advisories/GHSA-v3cg-7r9h-r2g6
- https://github.com/opensearch-project/OpenSearch/releases/tag/2.5.0
- https://github.com/opensearch-project/security/security/advisories/GHSA-v3cg-7r9h-r2g6
Get alerted when CVE-2023-23613 or the next vulnerability affects your stack