What’s Vulnerable › Vulnerabilities
CVE-2023-23616: Discourse membership requests lack character limit
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-28 · updated 2026-06-17
- Weakness: CWE-400
Description
Discourse is an open-source discussion platform. Prior to version 3.0.1 on the `stable` branch and 3.1.0.beta2 on the `beta` and `tests-passed` branches, when submitting a membership request, there is no character limit for the reason provided with the request. This could potentially allow a user to flood the database with a large amount of data. However it is unlikely this could be used as part of a DoS attack, as the paths reading back the reasons are only available to administrators. Starting in version 3.0.1 on the `stable` branch and 3.1.0.beta2 on the `beta` and `tests-passed` branches, a limit of 280 characters has been introduced for membership requests.
Affected products
- discourse: before 3.0.1; 1.1.0-beta1, 1.1.0-beta2, 1.1.0-beta3, 1.1.0-beta4, 1.1.0-beta5, 1.1.0-beta6 (+201) — fixed in 3.0.1
How to fix
Upgrade to a fixed version: discourse 3.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/3e0cc4a5d9ef44ad902f6985d046ebb32f0a14ee
- https://github.com/discourse/discourse/commit/d5745d34c20c31a221039d8913f33064433003ea
- https://github.com/discourse/discourse/pull/19993
- https://github.com/discourse/discourse/security/advisories/GHSA-6xff-p329-9pgf
- https://github.com/discourse/discourse/commit/3e0cc4a5d9ef44ad902f6985d046ebb32f0a14ee
- https://github.com/discourse/discourse/commit/d5745d34c20c31a221039d8913f33064433003ea
- https://github.com/discourse/discourse/pull/19993
- https://github.com/discourse/discourse/security/advisories/GHSA-6xff-p329-9pgf
Get alerted when CVE-2023-23616 or the next vulnerability affects your stack