What’s Vulnerable › Vulnerabilities
CVE-2023-23617: OpenMage LTS has DoS vulnerability in MaliciousCode filter
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-28 · updated 2026-06-17
- Weakness: CWE-835
Description
OpenMage LTS is an e-commerce platform. Versions prior to 19.4.22 and 20.0.19 contain an infinite loop in malicious code filter in certain conditions. Versions 19.4.22 and 20.0.19 have a fix for this issue. There are no known workarounds.
Affected products
- OpenMage magento-lts: before 19.4.22; from 20.0.0 before 20.0.19 — fixed in 19.4.22, 20.0.19
How to fix
Upgrade to a fixed version: OpenMage magento-lts 19.4.22, 20.0.19. Check the vendor advisory for mitigations.
References
- https://github.com/OpenMage/magento-lts/commit/494027785bdb7db53e60c11ef03c144b61cd3172
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.22
- https://github.com/OpenMage/magento-lts/releases/tag/v20.0.19
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-3p73-mm7v-4f6m
- https://github.com/OpenMage/magento-lts/commit/494027785bdb7db53e60c11ef03c144b61cd3172
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.22
- https://github.com/OpenMage/magento-lts/releases/tag/v20.0.19
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-3p73-mm7v-4f6m
Get alerted when CVE-2023-23617 or the next vulnerability affects your stack