What’s Vulnerable › Vulnerabilities
CVE-2023-23619: Improper Control of Generation of Code ('Code Injection') in @asyncapi/modelina
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-26 · updated 2026-06-17
- Weakness: CWE-94
Description
Modelina is a library for generating data models based on inputs such as AsyncAPI, OpenAPI, or JSON Schema documents. Versions prior to 1.0.0 are vulnerable to Code injection. This issue affects anyone who is using the default presets and/or does not handle the functionality themself. This issue has been partially mitigated in version 1.0.0, with the maintainer's GitHub Security Advisory (GHSA) noting "It is impossible to fully guard against this, because users have access to the original raw information. However, as of version 1, if you only access the constrained models, you will not encounter this issue. Further similar situations are NOT seen as a security issue, but intended behavior." The suggested workaround from the maintainers is "Fully custom presets that change the entire rendering process which can then escape the user input."
Affected products
- asyncapi modelina: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: asyncapi modelina 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/asyncapi/modelina/security/advisories/GHSA-4jg2-84c2-pj95
- https://github.com/asyncapi/modelina/security/advisories/GHSA-4jg2-84c2-pj95
Get alerted when CVE-2023-23619 or the next vulnerability affects your stack