What’s Vulnerable › Vulnerabilities
CVE-2023-23621: Discourse vulnerable to ReDoS in user agent parsing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-28 · updated 2026-06-17
- Weakness: CWE-1333
Description
Discourse is an open-source discussion platform. Prior to version 3.0.1 on the `stable` branch and version 3.1.0.beta2 on the `beta` and `tests-passed` branches, a malicious user can cause a regular expression denial of service using a carefully crafted user agent. This issue is patched in version 3.0.1 on the `stable` branch and version 3.1.0.beta2 on the `beta` and `tests-passed` branches. There are no known workarounds.
Affected products
- discourse: before 3.0.1; 1.1.0-beta1, 1.1.0-beta2, 1.1.0-beta3, 1.1.0-beta4, 1.1.0-beta5, 1.1.0-beta6 (+201) — fixed in 3.0.1
How to fix
Upgrade to a fixed version: discourse 3.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/6d92c3cbdac431db99a450f360a3048bb3aaf458
- https://github.com/discourse/discourse/pull/20002
- https://github.com/discourse/discourse/security/advisories/GHSA-mrfp-54hf-jrcv
- https://github.com/discourse/discourse/commit/6d92c3cbdac431db99a450f360a3048bb3aaf458
- https://github.com/discourse/discourse/pull/20002
- https://github.com/discourse/discourse/security/advisories/GHSA-mrfp-54hf-jrcv
Get alerted when CVE-2023-23621 or the next vulnerability affects your stack