What’s Vulnerable › Vulnerabilities
CVE-2023-23624: Discourse's exclude_tags param could leak which topics had a specific hidden tag
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-28 · updated 2026-06-17
- Weakness: CWE-200
Description
Discourse is an open-source discussion platform. Prior to version 3.0.1 on the `stable` branch and version 3.1.0.beta2 on the `beta` and `tests-passed` branches, someone can use the `exclude_tag param` to filter out topics and deduce which ones were using a specific hidden tag. This affects any Discourse site using hidden tags in public categories. This issue is patched in version 3.0.1 on the `stable` branch and version 3.1.0.beta2 on the `beta` and `tests-passed` branches. As a workaround, secure any categories that are using hidden tags, change any existing hidden tags to not include private data, or remove any hidden tags currently in use.
Affected products
- discourse: before 3.0.1; 1.1.0-beta1, 1.1.0-beta2, 1.1.0-beta3, 1.1.0-beta4, 1.1.0-beta5, 1.1.0-beta6 (+201) — fixed in 3.0.1
How to fix
Upgrade to a fixed version: discourse 3.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/f55e0fe7910149c431861c18ce407d1be0d6091a
- https://github.com/discourse/discourse/pull/20006
- https://github.com/discourse/discourse/security/advisories/GHSA-qgj5-g5vf-fm7q
- https://github.com/discourse/discourse/commit/f55e0fe7910149c431861c18ce407d1be0d6091a
- https://github.com/discourse/discourse/pull/20006
- https://github.com/discourse/discourse/security/advisories/GHSA-qgj5-g5vf-fm7q
Get alerted when CVE-2023-23624 or the next vulnerability affects your stack