What’s Vulnerable › Vulnerabilities
CVE-2023-23625: Denial of service in HAMT Decoding in go-unixfs
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-09 · updated 2026-06-17
- Weakness: CWE-400
Description
go-unixfs is an implementation of a unix-like filesystem on top of an ipld merkledag. Trying to read malformed HAMT sharded directories can cause panics and virtual memory leaks. If you are reading untrusted user input, an attacker can then trigger a panic. This is caused by bogus `fanout` parameter in the HAMT directory nodes. Users are advised to upgrade to version 0.4.3 to resolve this issue. Users unable to upgrade should not feed untrusted user data to the decoding functions.
Affected products
- ipfs go-unixfs: before 0.4.3 — fixed in 0.4.3
How to fix
Upgrade to a fixed version: ipfs go-unixfs 0.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/ipfs/go-unixfs/commit/467d139a640ecee4f2e74643dafcc58bb3b54175
- https://github.com/ipfs/go-unixfs/security/advisories/GHSA-q264-w97q-q778
- https://github.com/ipfs/go-unixfs/commit/467d139a640ecee4f2e74643dafcc58bb3b54175
- https://github.com/ipfs/go-unixfs/security/advisories/GHSA-q264-w97q-q778
Get alerted when CVE-2023-23625 or the next vulnerability affects your stack