What’s Vulnerable › Vulnerabilities
CVE-2023-23632
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-12 · updated 2026-06-17
- Weakness: CWE-287
Description
BeyondTrust Privileged Remote Access (PRA) versions 22.2.x to 22.4.x are vulnerable to a local authentication bypass. Attackers can exploit a flawed secret verification process in the BYOT shell jump sessions, allowing unauthorized access to jump items by guessing only the first character of the secret.
Affected products
- BeyondTrust Privileged Remote Access: from 22.2.1 before 22.3.3 — fixed in 22.3.3
How to fix
Upgrade to a fixed version: BeyondTrust Privileged Remote Access 22.3.3. Check the vendor advisory for mitigations.
References
- https://www.compass-security.com/fileadmin/Research/Advisories/2023_03_CSNC-2022-018_PRA_Privilege_Escalation.txt
- http://seclists.org/fulldisclosure/2025/May/1
- https://www.compass-security.com/fileadmin/Research/Advisories/2023_03_CSNC-2022-018_PRA_Privilege_Escalation.txt
Get alerted when CVE-2023-23632 or the next vulnerability affects your stack