What’s Vulnerable › Vulnerabilities
CVE-2023-23752: Joomla! Improper Access Control Vulnerability
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2024-01-08
- EPSS: 99.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-16 · updated 2026-06-17
- Weakness: CWE-284
Description
An issue was discovered in Joomla! 4.0.0 through 4.2.7. An improper access check allows unauthorized access to webservice endpoints.
Affected products
- Joomla!: from 4.0.0 before 4.2.8 — fixed in 4.2.8
How to fix
Upgrade to a fixed version: Joomla! 4.2.8. Check the vendor advisory for mitigations.
References
- https://developer.joomla.org/security-centre/894-20230201-core-improper-access-check-in-webservice-endpoints.html
- https://developer.joomla.org/security-centre/894-20230201-core-improper-access-check-in-webservice-endpoints.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-23752
Get alerted when CVE-2023-23752 or the next vulnerability affects your stack