What’s Vulnerable › Vulnerabilities
CVE-2023-23761: Improper authentication vulnerability in GitHub Enterprise Server leading to modification of secret gists
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-07 · updated 2026-06-17
- Weakness: CWE-287
Description
An improper authentication vulnerability was identified in GitHub Enterprise Server that allowed an unauthorized actor to modify other users' secret gists by authenticating through an SSH certificate authority. To do so, a user had to know the secret gist's URL. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.9 and was fixed in versions 3.4.18, 3.5.15, 3.6.11, 3.7.8, and 3.8.1. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
- GitHub Enterprise Server: before 3.4.18; from 3.5.0 before 3.5.15; from 3.6.0 before 3.6.11; from 3.7.0 before 3.7.8; 3.8.0 — fixed in 3.4.18, 3.5.15, 3.6.11, 3.7.8
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.4.18, 3.5.15, 3.6.11, 3.7.8. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.4/admin/release-notes#3.4.18
- https://docs.github.com/en/enterprise-server@3.5/admin/release-notes#3.5.15
- https://docs.github.com/en/enterprise-server@3.6/admin/release-notes#3.6.11
- https://docs.github.com/en/enterprise-server@3.7/admin/release-notes#3.7.8
- https://docs.github.com/en/enterprise-server@3.8/admin/release-notes#3.8.1
- https://docs.github.com/en/enterprise-server@3.4/admin/release-notes#3.4.18
- https://docs.github.com/en/enterprise-server@3.5/admin/release-notes#3.5.15
- https://docs.github.com/en/enterprise-server@3.6/admin/release-notes#3.6.11
- https://docs.github.com/en/enterprise-server@3.7/admin/release-notes#3.7.8
- https://docs.github.com/en/enterprise-server@3.8/admin/release-notes#3.8.1
Get alerted when CVE-2023-23761 or the next vulnerability affects your stack