What’s Vulnerable › Vulnerabilities

CVE-2023-23762: Incorrect comparison vulnerability in GitHub Enterprise Server leading to commit smuggling

Description

An incorrect comparison vulnerability was identified in GitHub Enterprise Server that allowed commit smuggling by displaying an incorrect diff. To do so, an attacker would need write access to the repository and be able to correctly guess the target branch before it’s created by the code maintainer. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.9 and was fixed in versions 3.4.18, 3.5.15, 3.6.11, 3.7.8, and 3.8.1. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

How to fix

Upgrade to a fixed version: GitHub Enterprise Server 3.4.18, 3.5.15, 3.6.11, 3.7.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-23762 or the next vulnerability affects your stack