What’s Vulnerable › Vulnerabilities
CVE-2023-23764: Incorrect comparison vulnerability in GitHub Enterprise Server leading to commit smuggling
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-27 · updated 2026-06-17
- Weakness: CWE-697
Description
An incorrect comparison vulnerability was identified in GitHub Enterprise Server that allowed commit smuggling by displaying an incorrect diff within the GitHub pull request UI. To do so, an attacker would need write access to the repository. This vulnerability affected GitHub Enterprise Server versions 3.7.0 and above and was fixed in versions 3.7.9, 3.8.2, and 3.9.1. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
- GitHub Enterprise Server: from 3.7.0 before 3.7.9; from 3.8.0 before 3.8.2; 3.9.0 — fixed in 3.7.9, 3.8.2
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.7.9, 3.8.2. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.7/admin/release-notes#3.7.9
- https://docs.github.com/en/enterprise-server@3.8/admin/release-notes#3.8.2
- https://docs.github.com/en/enterprise-server@3.9/admin/release-notes#3.9.1
- https://docs.github.com/en/enterprise-server@3.7/admin/release-notes#3.7.9
- https://docs.github.com/en/enterprise-server@3.8/admin/release-notes#3.8.2
- https://docs.github.com/en/enterprise-server@3.9/admin/release-notes#3.9.1
Get alerted when CVE-2023-23764 or the next vulnerability affects your stack