What’s Vulnerable › Vulnerabilities
CVE-2023-23780
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-16 · updated 2026-06-17
- Weakness: CWE-121
Description
A stack-based buffer overflow in Fortinet FortiWeb version 7.0.0 through 7.0.1, Fortinet FortiWeb version 6.3.6 through 6.3.19, Fortinet FortiWeb 6.4 all versions allows attacker to escalation of privilege via specifically crafted HTTP requests.
Affected products
- Fortinet FortiWeb: from 6.3.0 before 6.3.20; from 6.4.0 through 6.4.2; from 7.0.0 before 7.0.2 — fixed in 6.3.20, 7.0.2
How to fix
Upgrade to a fixed version: Fortinet FortiWeb 6.3.20, 7.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-23780 or the next vulnerability affects your stack