What’s Vulnerable › Vulnerabilities

CVE-2023-23781

Description

A stack-based buffer overflow vulnerability [CWE-121] in FortiWeb version 7.0.1 and below, 6.4 all versions, version 6.3.19 and below SAML server configuration may allow an authenticated attacker to achieve arbitrary code execution via specifically crafted XML files.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiWeb 6.3.20, 7.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-23781 or the next vulnerability affects your stack