What’s Vulnerable › Vulnerabilities
CVE-2023-23792: WordPress Swatchly – WooCommerce Variation Swatches for Products Plugin <= 1.2.0 is vulnerable to Cross Site Request Forgery (CSRF)
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-11 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in HasThemes Swatchly plugin <= 1.2.0 versions.
Affected products
- HasThemes Swatchly: before 1.2.1 — fixed in 1.2.1
How to fix
Upgrade to a fixed version: HasThemes Swatchly 1.2.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/swatchly/wordpress-swatchly-woocommerce-variation-swatches-for-products-product-attributes-image-swatch-color-swatches-label-swatches-plugin-1-1-9-cross-site-request-forgery-csrf-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/swatchly/wordpress-swatchly-woocommerce-variation-swatches-for-products-product-attributes-image-swatch-color-swatches-label-swatches-plugin-1-1-9-cross-site-request-forgery-csrf-vulnerability?_s_id=cve
Get alerted when CVE-2023-23792 or the next vulnerability affects your stack