What’s Vulnerable › Vulnerabilities
CVE-2023-23835
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-14 · updated 2026-06-17
- Weakness: CWE-284
Description
A vulnerability has been identified in Mendix Applications using Mendix 7 (All versions < V7.23.34), Mendix Applications using Mendix 8 (All versions < V8.18.23), Mendix Applications using Mendix 9 (All versions < V9.22.0), Mendix Applications using Mendix 9 (V9.12) (All versions < V9.12.10), Mendix Applications using Mendix 9 (V9.18) (All versions < V9.18.4), Mendix Applications using Mendix 9 (V9.6) (All versions < V9.6.15). Some of the Mendix runtime API’s allow attackers to bypass XPath constraints and retrieve information using XPath queries that trigger errors.
Affected products
- Siemens Mendix Applications using Mendix 7: from 7.0.2 before 7.23.34; from 8.0.0 before 8.18.23; from 9.0.0 before 9.6.15; from 9.7.0 before 9.12.10; from 9.18.0 before 9.18.4; from 9.19.0 before 9.22.0 — fixed in 7.23.34, 8.18.23, 9.12.10, 9.18.4, 9.22.0, 9.6.15
How to fix
Upgrade to a fixed version: Siemens Mendix Applications using Mendix 7 7.23.34, 8.18.23, 9.12.10, 9.18.4. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-252808.pdf
- https://cert-portal.siemens.com/productcert/pdf/ssa-252808.pdf
Get alerted when CVE-2023-23835 or the next vulnerability affects your stack