What’s Vulnerable › Vulnerabilities
CVE-2023-23846
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-01 · updated 2026-06-17
- Weakness: CWE-770
Description
Due to insufficient length validation in the Open5GS GTP library versions prior to versions 2.4.13 and 2.5.7, when parsing extension headers in GPRS tunneling protocol (GPTv1-U) messages, a protocol payload with any extension header length set to zero causes an infinite loop. The affected process becomes immediately unresponsive, resulting in denial of service and excessive resource consumption. CVSS3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P/RL:O/RC:C
Affected products
- Open5GS: before 2.4.13; 2.5.6 — fixed in 2.4.13
How to fix
Upgrade to a fixed version: Open5GS 2.4.13. Check the vendor advisory for mitigations.
References
- https://www.synopsys.com/blogs/software-security/cyrc-advisory-open5gs-gtp-library/
- https://www.synopsys.com/blogs/software-security/cyrc-advisory-open5gs-gtp-library/
Get alerted when CVE-2023-23846 or the next vulnerability affects your stack