What’s Vulnerable › Vulnerabilities
CVE-2023-23847
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-15 · updated 2026-06-17
- Weakness: CWE-352
Description
A cross-site request forgery (CSRF) vulnerability in Synopsys Jenkins Coverity Plugin 3.0.2 and earlier allows attackers to connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
Affected products
- Synopsys Jenkins Coverity Plugin: before 3.0.3 — fixed in 3.0.3
How to fix
Upgrade to a fixed version: Synopsys Jenkins Coverity Plugin 3.0.3. Check the vendor advisory for mitigations.
References
- https://community.synopsys.com/s/article/SIG-Product-Security-Advisory-Multiple-CVEs-affecting-Coverity-Jenkins-Plugin
- https://www.jenkins.io/security/advisory/2023-02-15/#SECURITY-2793%20%282%29
- https://community.synopsys.com/s/article/SIG-Product-Security-Advisory-Multiple-CVEs-affecting-Coverity-Jenkins-Plugin
- https://www.jenkins.io/security/advisory/2023-02-15/#SECURITY-2793%20%282%29
Get alerted when CVE-2023-23847 or the next vulnerability affects your stack