What’s Vulnerable › Vulnerabilities
CVE-2023-23849
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Versions of Coverity Connect prior to 2022.12.0 are vulnerable to an unauthenticated Cross-Site Scripting vulnerability. Any web service hosted on the same sub domain can set a cookie for the whole subdomain which can be used to bypass other mitigations in place for malicious purposes. CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/RL:O/RC:C
Affected products
- Synopsys Coverity: before 2022.12.0 — fixed in 2022.12.0
How to fix
Upgrade to a fixed version: Synopsys Coverity 2022.12.0. Check the vendor advisory for mitigations.
References
- https://community.synopsys.com/s/article/SIG-Product-Security-Advisory-CVE-2023-23849-affecting-Coverity
- https://community.synopsys.com/s/article/SIG-Product-Security-Advisory-CVE-2023-23849-affecting-Coverity
Get alerted when CVE-2023-23849 or the next vulnerability affects your stack