What’s Vulnerable › Vulnerabilities
CVE-2023-23863: WordPress TreePress – Easy Family Trees & Ancestor Profiles Plugin <= 2.0.22 is vulnerable to Cross Site Scripting (XSS)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Black and White Digital Ltd TreePress – Easy Family Trees & Ancestor Profiles plugin <= 2.0.22 versions.
Affected products
- Black and White Digital Ltd TreePress – Easy Family Trees & Ancestor Profiles: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: Black and White Digital Ltd TreePress – Easy Family Trees & Ancestor Profiles 3.0.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/treepress/wordpress-treepress-easy-family-trees-ancestor-profiles-plugin-2-0-22-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/treepress/wordpress-treepress-easy-family-trees-ancestor-profiles-plugin-2-0-22-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2023-23863 or the next vulnerability affects your stack