What’s Vulnerable › Vulnerabilities
CVE-2023-23865: WordPress Stripe Payments For WooCommerce by Checkout Plugin <= 1.4.10 is vulnerable to Cross Site Request Forgery (CSRF)
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-28 · updated 2026-06-17
- Weakness: CWE-352
Description
Cross-Site Request Forgery (CSRF) vulnerability in Checkout Plugins Stripe Payments For WooCommerce plugin <= 1.4.10 leads to settings change.
Affected products
- Checkout Plugins Stripe Payments For WooCommerce by Checkout: before 1.4.11 — fixed in 1.4.11
How to fix
Upgrade to a fixed version: Checkout Plugins Stripe Payments For WooCommerce by Checkout 1.4.11. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/checkout-plugins-stripe-woo/wordpress-stripe-payments-for-woocommerce-by-checkout-plugins-plugin-1-4-10-cross-site-request-forgery-csrf-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/checkout-plugins-stripe-woo/wordpress-stripe-payments-for-woocommerce-by-checkout-plugins-plugin-1-4-10-cross-site-request-forgery-csrf-vulnerability?_s_id=cve
Get alerted when CVE-2023-23865 or the next vulnerability affects your stack