What’s Vulnerable › Vulnerabilities
CVE-2023-23876: WordPress wpDataTables Plugin <= 2.1.49 is vulnerable to Cross Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in TMS-Plugins wpDataTables plugin <= 2.1.49 versions.
Affected products
- wpDataTables – WordPress Data Table, Dynamic Tables & Table Charts Plugin: before 2.1.50 — fixed in 2.1.50
How to fix
Upgrade to a fixed version: wpDataTables – WordPress Data Table, Dynamic Tables & Table Charts Plugin 2.1.50. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wpdatatables/wordpress-wpdatatables-wordpress-tables-table-charts-plugin-plugin-2-1-49-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/wpdatatables/wordpress-wpdatatables-wordpress-tables-table-charts-plugin-plugin-2-1-49-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2023-23876 or the next vulnerability affects your stack