What’s Vulnerable › Vulnerabilities

CVE-2023-23918

Description

A privilege escalation vulnerability exists in Node.js <19.6.1, <18.14.1, <16.19.1 and <14.21.3 that made it possible to bypass the experimental Permissions (https://nodejs.org/api/permissions.html) feature in Node.js and access non authorized modules by using process.mainModule.require(). This only affects users who had enabled the experimental permissions option with --experimental-policy.

Affected products

How to fix

Upgrade to a fixed version: Node.js 14.21.3, 16.19.1, 18.14.1, 19.6.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-23918 or the next vulnerability affects your stack