What’s Vulnerable › Vulnerabilities

CVE-2023-23919

Description

A cryptographic vulnerability exists in Node.js <19.2.0, <18.14.1, <16.19.1, <14.21.3 that in some cases did does not clear the OpenSSL error stack after operations that may set it. This may lead to false positive errors during subsequent cryptographic operations that happen to be on the same thread. This in turn could be used to cause a denial of service.

Affected products

How to fix

Upgrade to a fixed version: Node.js 14.21.3, 16.19.1, 18.14.1, 19.2.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-23919 or the next vulnerability affects your stack