What’s Vulnerable › Vulnerabilities
CVE-2023-23922: Moodle: reflected xss risk in blog search
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The vulnerability was found Moodle which exists due to insufficient sanitization of user-supplied data in blog search. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website. This flaw allows a remote attacker to perform cross-site scripting (XSS) attacks.
Affected products
- Moodle: from 4.0.0 before 4.0.6; 4.1.0 — fixed in 4.0.6
How to fix
Upgrade to a fixed version: Moodle 4.0.6. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-76861
- https://bugzilla.redhat.com/show_bug.cgi?id=2162547
- https://moodle.org/mod/forum/discuss.php?d=443273#p1782022
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-76861
- https://bugzilla.redhat.com/show_bug.cgi?id=2162547
- https://moodle.org/mod/forum/discuss.php?d=443273#p1782022
Get alerted when CVE-2023-23922 or the next vulnerability affects your stack