What’s Vulnerable › Vulnerabilities
CVE-2023-23923: Moodle: possible to set the preferred "start page" of other users
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-17 · updated 2026-06-17
- Weakness: CWE-284
Description
The vulnerability was found Moodle which exists due to insufficient limitations on the "start page" preference. A remote attacker can set that preference for another user. The vulnerability allows a remote attacker to gain unauthorized access to otherwise restricted functionality.
Affected products
- Moodle: from 3.9.0 before 3.9.19; from 3.11.0 before 3.11.12; from 4.0.0 before 4.0.6; 4.1.0 — fixed in 3.11.12, 3.9.19, 4.0.6
How to fix
Upgrade to a fixed version: Moodle 3.11.12, 3.9.19, 4.0.6. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-76862
- https://bugzilla.redhat.com/show_bug.cgi?id=2162549
- https://moodle.org/mod/forum/discuss.php?d=443274#p1782023
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-76862
- https://bugzilla.redhat.com/show_bug.cgi?id=2162549
- https://moodle.org/mod/forum/discuss.php?d=443274#p1782023
Get alerted when CVE-2023-23923 or the next vulnerability affects your stack