What’s Vulnerable › Vulnerabilities
CVE-2023-23927: Craft CMS stored cross-site scripting vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Craft is a platform for creating digital experiences. When you insert a payload inside a label name or instruction of an entry type, an cross-site scripting (XSS) happens in the quick post widget on the admin dashboard. This issue has been fixed in version 4.3.7.
Affected products
- craftcms cms: before 4.3.7 — fixed in 4.3.7
How to fix
Upgrade to a fixed version: craftcms cms 4.3.7. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/blob/develop/CHANGELOG.md#437---2023-02-03
- https://github.com/craftcms/cms/security/advisories/GHSA-qcrj-6ffc-v7hq
- https://user-images.githubusercontent.com/53917092/215604129-d5b75608-5a24-4eb3-906f-55b192310298.mp4
- https://github.com/craftcms/cms/blob/develop/CHANGELOG.md#437---2023-02-03
- https://github.com/craftcms/cms/security/advisories/GHSA-qcrj-6ffc-v7hq
- https://user-images.githubusercontent.com/53917092/215604129-d5b75608-5a24-4eb3-906f-55b192310298.mp4
Get alerted when CVE-2023-23927 or the next vulnerability affects your stack