What’s Vulnerable › Vulnerabilities
CVE-2023-23938: Cross-site Scripting (XSS) through the name of a color of select box values in tuleap
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Tuleap is a Free & Source tool for end to end traceability of application and system developments. Affected versions are subject to a cross site scripting attack which can be injected in the name of a color of select box values of a tracker and then reflected in the tracker administration. Administrative privilege is required, but an attacker with tracker administration rights could use this vulnerability to force a victim to execute uncontrolled code in the context of their browser. This issue has been addressed in Tuleap Community Edition version 14.5.99.4. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- Enalean tuleap: before 14.4-7; from 13.8.99.49 before 14.5.99.4; from 14.5 before 14.5-2 — fixed in 14.4-7, 14.5-2, 14.5.99.4
How to fix
Upgrade to a fixed version: Enalean tuleap 14.4-7, 14.5-2, 14.5.99.4. Check the vendor advisory for mitigations.
References
- https://github.com/Enalean/tuleap/commit/aacd5e798301f24f218298ec8236ec7bef0f5d52
- https://github.com/Enalean/tuleap/security/advisories/GHSA-mqjm-c6rm-9h87
- https://tuleap.net/plugins/tracker/?aid=30734
- https://github.com/Enalean/tuleap/commit/aacd5e798301f24f218298ec8236ec7bef0f5d52
- https://github.com/Enalean/tuleap/security/advisories/GHSA-mqjm-c6rm-9h87
- https://tuleap.net/plugins/tracker/?aid=30734
Get alerted when CVE-2023-23938 or the next vulnerability affects your stack