What’s Vulnerable › Vulnerabilities
CVE-2023-23946: Git's `git apply` overwriting paths outside the working tree
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-14 · updated 2026-10-08
- Weakness: CWE-22
Description
Git, a revision control system, is vulnerable to path traversal prior to versions 2.39.2, 2.38.4, 2.37.6, 2.36.5, 2.35.7, 2.34.7, 2.33.7, 2.32.6, 2.31.7, and 2.30.8. By feeding a crafted input to `git apply`, a path outside the working tree can be overwritten as the user who is running `git apply`. A fix has been prepared and will appear in v2.39.2, v2.38.4, v2.37.6, v2.36.5, v2.35.7, v2.34.7, v2.33.7, v2.32.6, v2.31.7, and v2.30.8. As a workaround, use `git apply --stat` to inspect a patch before applying; avoid applying one that creates a symbolic link and then creates a file beyond the symbolic link.
Affected products
- git: before 2.30.8; from 2.31.0 before 2.31.7; from 2.32.0 before 2.32.6; from 2.33.0 before 2.33.7; from 2.34.0 before 2.34.7; from 2.35.0 before 2.35.7 — fixed in 2.30.8, 2.31.7, 2.32.6, 2.33.7, 2.34.7, 2.35.7
How to fix
Upgrade to a fixed version: git 2.30.8, 2.31.7, 2.32.6, 2.33.7. Check the vendor advisory for mitigations.
References
- https://github.com/git/git/commit/c867e4fa180bec4750e9b54eb10f459030dbebfd
- https://github.com/git/git/security/advisories/GHSA-r87m-v37r-cwfh
- https://security.gentoo.org/glsa/202312-15
- https://github.com/git/git/commit/c867e4fa180bec4750e9b54eb10f459030dbebfd
- https://github.com/git/git/security/advisories/GHSA-r87m-v37r-cwfh
- https://security.gentoo.org/glsa/202312-15
Get alerted when CVE-2023-23946 or the next vulnerability affects your stack