What’s Vulnerable › Vulnerabilities
CVE-2023-2430
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-23 · updated 2026-06-17
- Weakness: CWE-413
Description
A vulnerability was found due to missing lock for IOPOLL flaw in io_cqring_event_overflow() in io_uring.c in Linux Kernel. This flaw allows a local attacker with user privilege to trigger a Denial of Service threat.
Affected products
- Linux kernel: before 6.2; 6.2, 6.2-rc1, 6.2-rc2, 6.2-rc3, 6.2-rc4 — fixed in 6.2
How to fix
Upgrade to a fixed version: Linux kernel 6.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=e12d7a46f65ae4b7d58a5e0c1cbfa825cf8
- https://www.debian.org/security/2023/dsa-5492
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=e12d7a46f65ae4b7d58a5e0c1cbfa825cf8
- https://www.debian.org/security/2023/dsa-5492
Get alerted when CVE-2023-2430 or the next vulnerability affects your stack