What’s Vulnerable › Vulnerabilities
CVE-2023-2442
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 96.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.11 before 15.11.7, all versions starting from 16.0 before 16.0.2. A specially crafted merge request could lead to a stored XSS on the client side which allows attackers to perform arbitrary actions on behalf of victims.
Affected products
- GitLab: from 15.11.0 before 15.11.7; from 16.0.0 before 16.0.2 — fixed in 15.11.7, 16.0.2
How to fix
Upgrade to a fixed version: GitLab 15.11.7, 16.0.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2023/CVE-2023-2442.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/409346
- https://hackerone.com/reports/1965750
- https://gitlab.com/gitlab-org/cves/-/blob/master/2023/CVE-2023-2442.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/409346
- https://hackerone.com/reports/1965750
- https://gitlab.com/gitlab-org/gitlab/-/issues/409346
Get alerted when CVE-2023-2442 or the next vulnerability affects your stack