What’s Vulnerable › Vulnerabilities
CVE-2023-24424
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-26 · updated 2026-06-17
- Weakness: CWE-384
Description
Jenkins OpenId Connect Authentication Plugin 2.4 and earlier does not invalidate the previous session on login.
Affected products
- Jenkins Project Jenkins OpenId Connect Authentication Plugin: before 2.5 — fixed in 2.5
How to fix
Upgrade to a fixed version: Jenkins Project Jenkins OpenId Connect Authentication Plugin 2.5. Check the vendor advisory for mitigations.
References
- https://www.jenkins.io/security/advisory/2023-01-24/#SECURITY-2978
- https://www.jenkins.io/security/advisory/2023-01-24/#SECURITY-2978
Get alerted when CVE-2023-24424 or the next vulnerability affects your stack