What’s Vulnerable › Vulnerabilities
CVE-2023-24429
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-26 · updated 2026-06-17
- Weakness: CWE-611
Description
Jenkins Semantic Versioning Plugin 1.14 and earlier does not restrict execution of an controller/agent message to agents, and implements no limitations about the file path that can be parsed, allowing attackers able to control agent processes to have Jenkins parse a crafted file that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery.
Affected products
- Jenkins Project Jenkins Semantic Versioning Plugin: before 1.15 — fixed in 1.15
How to fix
Upgrade to a fixed version: Jenkins Project Jenkins Semantic Versioning Plugin 1.15. Check the vendor advisory for mitigations.
References
- https://www.jenkins.io/security/advisory/2023-01-24/#SECURITY-2973%20%281%29
- https://www.jenkins.io/security/advisory/2023-01-24/#SECURITY-2973%20%281%29
Get alerted when CVE-2023-24429 or the next vulnerability affects your stack