What’s Vulnerable › Vulnerabilities
CVE-2023-24430
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-26 · updated 2026-06-17
- Weakness: CWE-611
Description
Jenkins Semantic Versioning Plugin 1.14 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.
Affected products
- Jenkins Project Jenkins Semantic Versioning Plugin: before 1.15 — fixed in 1.15
How to fix
Upgrade to a fixed version: Jenkins Project Jenkins Semantic Versioning Plugin 1.15. Check the vendor advisory for mitigations.
References
- https://www.jenkins.io/security/advisory/2023-01-24/#SECURITY-2973%20%282%29
- https://www.jenkins.io/security/advisory/2023-01-24/#SECURITY-2973%20%282%29
Get alerted when CVE-2023-24430 or the next vulnerability affects your stack