What’s Vulnerable › Vulnerabilities
CVE-2023-2446: UserPro <= 5.1.1 - Sensitive Information Disclosure via Shortcode
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-22 · updated 2026-06-17
- Weakness: CWE-200
Description
The UserPro plugin for WordPress is vulnerable to sensitive information disclosure via the 'userpro' shortcode in versions up to, and including 5.1.1. This is due to insufficient restriction on sensitive user meta values that can be called via that shortcode. This makes it possible for authenticated attackers, with subscriber-level permissions, and above to retrieve sensitive user meta that can be used to gain access to a high privileged user account.
Affected products
- UserPro - Community and User Profile WordPress Plugin: before 5.1.2 — fixed in 5.1.2
How to fix
Upgrade to a fixed version: UserPro - Community and User Profile WordPress Plugin 5.1.2. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/userpro-user-profiles-with-social-login/5958681
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4072ba5f-6385-4fa3-85b6-89dac7b60a92?source=cve
- http://packetstormsecurity.com/files/175871/WordPress-UserPro-5.1.x-Password-Reset-Authentication-Bypass-Escalation.html
- https://codecanyon.net/item/userpro-user-profiles-with-social-login/5958681
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4072ba5f-6385-4fa3-85b6-89dac7b60a92?source=cve
Get alerted when CVE-2023-2446 or the next vulnerability affects your stack