What’s Vulnerable › Vulnerabilities
CVE-2023-2447: UserPro <= 5.1.1 - Cross-Site Request Forgery to Sensitive Information Exposure
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-22 · updated 2026-06-17
- Weakness: CWE-352
Description
The UserPro plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 5.1.1. This is due to missing or incorrect nonce validation on the 'export_users' function. This makes it possible for unauthenticated attackers to export the users to a csv file, granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- UserPro - Community and User Profile WordPress Plugin: before 5.1.2 — fixed in 5.1.2
How to fix
Upgrade to a fixed version: UserPro - Community and User Profile WordPress Plugin 5.1.2. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/userpro-user-profiles-with-social-login/5958681
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0372efe4-b5be-4601-be43-5c12332ea1a5?source=cve
- https://codecanyon.net/item/userpro-user-profiles-with-social-login/5958681
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0372efe4-b5be-4601-be43-5c12332ea1a5?source=cve
Get alerted when CVE-2023-2447 or the next vulnerability affects your stack