What’s Vulnerable › Vulnerabilities
CVE-2023-2454
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-09 · updated 2026-06-17
- Weakness: CWE-20
Description
schema_element defeats protective search_path changes; It was found that certain database calls in PostgreSQL could permit an authed attacker with elevated database-level privileges to execute arbitrary code.
Affected products
- Fedoraproject Fedora: 38
- PostgreSQL: from 11.0 before 11.20; from 12.0 before 12.15; from 13.0 before 13.11; from 14.0 before 14.8; from 15.0 before 15.3 — fixed in 11.20, 12.15, 13.11, 14.8, 15.3
- Red Hat Enterprise Linux: 8.0, 9.0
- RedHat Software Collections: all versions
How to fix
Upgrade to a fixed version: PostgreSQL 11.20, 12.15, 13.11, 14.8. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2023-2454
- https://security.netapp.com/advisory/ntap-20230706-0006/
- https://www.postgresql.org/support/security/CVE-2023-2454/
- https://access.redhat.com/security/cve/CVE-2023-2454
- https://security.netapp.com/advisory/ntap-20230706-0006/
- https://www.postgresql.org/support/security/CVE-2023-2454/
Get alerted when CVE-2023-2454 or the next vulnerability affects your stack