What’s Vulnerable › Vulnerabilities

CVE-2023-24544

Description

Improper access control vulnerability in Buffalo network devices allows a network-adjacent attacker to obtain specific files of the product. As a result, the product settings may be altered. The affected products and versions are as follows: BS-GSL2024 firmware Ver. 1.10-0.03 and earlier, BS-GSL2016P firmware Ver. 1.10-0.03 and earlier, BS-GSL2016 firmware Ver. 1.10-0.03 and earlier, BS-GS2008 firmware Ver. 1.0.10.01 and earlier, BS-GS2016 firmware Ver. 1.0.10.01 and earlier, BS-GS2024 firmware Ver. 1.0.10.01 and earlier, BS-GS2048 firmware Ver. 1.0.10.01 and earlier, BS-GS2008P firmware Ver. 1.0.10.01 and earlier, BS-GS2016P firmware Ver. 1.0.10.01 and earlier, and BS-GS2024P firmware Ver. 1.0.10.01 and earlier

Affected products

How to fix

Upgrade to a fixed version: Buffalo Bs-Gs2016Hp Firmware 1.1.7.01; Buffalo Bs-Gs2016P Firmware 1.1.7.01; Buffalo Bs-Gs2024Hp Firmware 1.1.7.01; Buffalo Bs-Gs2024P Firmware 1.1.7.01. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-24544 or the next vulnerability affects your stack