What’s Vulnerable › Vulnerabilities
CVE-2023-2455
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-09 · updated 2026-06-17
- Weakness: CWE-20
Description
Row security policies disregard user ID changes after inlining; PostgreSQL could permit incorrect policies to be applied in certain cases where role-specific policies are used and a given query is planned under one role and then executed under other roles. This scenario can happen under security definer functions or when a common user and query is planned initially and then re-used across multiple SET ROLEs. Applying an incorrect policy may permit a user to complete otherwise-forbidden reads and modifications. This affects only databases that have used CREATE POLICY to define a row security policy.
Affected products
- Fedoraproject Fedora: 38
- PostgreSQL: from 11.0 before 11.20; from 12.0 before 12.15; from 13.0 before 13.11; from 14.0 before 14.8; from 15.0 before 15.3 — fixed in 11.20, 12.15, 13.11, 14.8, 15.3
- Red Hat Enterprise Linux: 8.0, 9.0
- RedHat Software Collections: all versions
How to fix
Upgrade to a fixed version: PostgreSQL 11.20, 12.15, 13.11, 14.8. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2023-2455
- https://security.netapp.com/advisory/ntap-20230706-0006/
- https://www.postgresql.org/support/security/CVE-2023-2455/
- https://access.redhat.com/security/cve/CVE-2023-2455
- https://security.netapp.com/advisory/ntap-20230706-0006/
- https://www.postgresql.org/support/security/CVE-2023-2455/
Get alerted when CVE-2023-2455 or the next vulnerability affects your stack