What’s Vulnerable › Vulnerabilities
CVE-2023-24623
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-30 · updated 2026-06-17
- Weakness: CWE-918
Description
Paranoidhttp before 0.3.0 allows SSRF because [::] is equivalent to the 127.0.0.1 address, but does not match the filter for private addresses.
Affected products
- Paranoidhttp Project Paranoidhttp: before 0.3.0 — fixed in 0.3.0
How to fix
Upgrade to a fixed version: Paranoidhttp Project Paranoidhttp 0.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/hakobe/paranoidhttp/blob/master/CHANGELOG.md#v030-2023-01-19
- https://github.com/hakobe/paranoidhttp/commit/07f671da14ce63a80f4e52432b32e8d178d75fd3
- https://github.com/hakobe/paranoidhttp/compare/v0.2.0...v0.3.0
- https://github.com/hakobe/paranoidhttp/blob/master/CHANGELOG.md#v030-2023-01-19
- https://github.com/hakobe/paranoidhttp/commit/07f671da14ce63a80f4e52432b32e8d178d75fd3
- https://github.com/hakobe/paranoidhttp/compare/v0.2.0...v0.3.0
Get alerted when CVE-2023-24623 or the next vulnerability affects your stack