What’s Vulnerable › Vulnerabilities

CVE-2023-2478

Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.4 before 15.9.7, all versions starting from 15.10 before 15.10.6, all versions starting from 15.11 before 15.11.2. Under certain conditions, a malicious unauthorized GitLab user may use a GraphQL endpoint to attach a malicious runner to any project.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.10.6, 15.11.2, 15.9.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-2478 or the next vulnerability affects your stack