What’s Vulnerable › Vulnerabilities
CVE-2023-24837: HGiga PowerStation - Command Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-27 · updated 2026-06-17
- Weakness: CWE-78
Description
HGiga PowerStation remote management function has insufficient filtering for user input. An authenticated remote attacker with general user privilege can exploit this vulnerability to inject and execute arbitrary system commands to perform arbitrary system operation or disrupt service.
Affected products
- HGiga PowerStation: before x64.6.2.165 — fixed in x64.6.2.165
How to fix
Upgrade to a fixed version: HGiga PowerStation x64.6.2.165. Check the vendor advisory for mitigations.
References
- https://www.twcert.org.tw/tw/cp-132-6956-fbd85-1.html
- https://www.twcert.org.tw/tw/cp-132-6956-fbd85-1.html
Get alerted when CVE-2023-24837 or the next vulnerability affects your stack