What’s Vulnerable › Vulnerabilities
CVE-2023-24909: Microsoft PostScript and PCL6 Class Printer Driver Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-14 · updated 2026-06-17
- Weakness: CWE-190
Description
Microsoft PostScript and PCL6 Class Printer Driver Remote Code Execution Vulnerability
Affected products
- Microsoft Windows 10 1607: before 10.0.14393.5786 — fixed in 10.0.14393.5786
- Microsoft Windows 10: before 10.0.17763.4131 — fixed in 10.0.17763.4131
- Microsoft Windows 10 20H2: before 10.0.19042.2728 — fixed in 10.0.19042.2728
- Microsoft Windows 10: before 10.0.19044.2728 — fixed in 10.0.19044.2728
- Microsoft Windows 10: before 10.0.19045.2728 — fixed in 10.0.19045.2728
- Microsoft Windows 11 21H2: before 10.0.22000.1696 — fixed in 10.0.22000.1696
- Microsoft Windows 11: before 10.0.22000.1413 — fixed in 10.0.22000.1413
- Microsoft Windows Server 2012: r2
- Microsoft Windows Server 2016: all versions
- Microsoft Windows Server 2019: all versions
- Microsoft Windows Server 2022: all versions
- Microsoft Windows 10 Version 1507: from 10.0.10240.0 before 10.0.10240.19805 — fixed in 10.0.10240.19805
- Microsoft Windows 10 1607: from 10.0.14393.0 before 10.0.14393.5786 — fixed in 10.0.14393.5786
- Microsoft Windows 10: from 10.0.17763.0 before 10.0.17763.4131 — fixed in 10.0.17763.4131
- Microsoft Windows 10 20H2: from 10.0.0 before 10.0.19042.2728 — fixed in 10.0.19042.2728
- Microsoft Windows 10: from 10.0.19043.0 before 10.0.19044.2728 — fixed in 10.0.19044.2728
- Microsoft Windows 10: from 10.0.19045.0 before 10.0.19045.2728 — fixed in 10.0.19045.2728
- Microsoft Windows 11 21H2: from 10.0.0 before 10.0.22000.1696 — fixed in 10.0.22000.1696
- Microsoft Windows 11: from 10.0.22621.0 before 10.0.22621.1413 — fixed in 10.0.22621.1413
- Microsoft Windows Server 2012: from 6.2.9200.0 before 6.2.9200.24168 — fixed in 6.2.9200.24168
- Microsoft Windows Server 2012 R2: from 6.3.9600.0 before 6.3.9600.20865 — fixed in 6.3.9600.20865
- Microsoft Windows Server 2016: from 10.0.14393.0 before 10.0.14393.5786 — fixed in 10.0.14393.5786
- Microsoft Windows Server 2019: from 10.0.17763.0 before 10.0.17763.4131 — fixed in 10.0.17763.4131
- Microsoft Windows Server 2022: from 10.0.20348.0 before 10.0.20348.1607 — fixed in 10.0.20348.1607
How to fix
Upgrade to a fixed version: Microsoft Windows 10 1607 10.0.14393.5786; Microsoft Windows 10 10.0.17763.4131; Microsoft Windows 10 20H2 10.0.19042.2728; Microsoft Windows 10 10.0.19044.2728; Microsoft Windows 10 10.0.19045.2728; Microsoft Windows 11 21H2 10.0.22000.1696; Microsoft Windows 11 10.0.22000.1413; Microsoft Windows 10 Version 1507 10.0.10240.19805; Microsoft Windows 10 1607 10.0.14393.5786; Microsoft Windows 10 10.0.17763.4131; Microsoft Windows 10 20H2 10.0.19042.2728; Microsoft Windows 10 10.0.19044.2728. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-24909
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-24909
Get alerted when CVE-2023-24909 or the next vulnerability affects your stack