What’s Vulnerable › Vulnerabilities
CVE-2023-24924: Microsoft PostScript and PCL6 Class Printer Driver Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-11 · updated 2026-06-17
- Weakness: CWE-125
Description
Microsoft PostScript and PCL6 Class Printer Driver Remote Code Execution Vulnerability
Affected products
- Microsoft Windows 10 Version 1507: before 10.0.10240.19869 — fixed in 10.0.10240.19869
- Microsoft Windows 10 1607: before 10.0.14393.5850 — fixed in 10.0.14393.5850
- Microsoft Windows 10: before 10.0.17763.4252 — fixed in 10.0.17763.4252
- Microsoft Windows 10 20H2: before 10.0.19042.2846 — fixed in 10.0.19042.2846
- Microsoft Windows 10: before 10.0.19044.2846 — fixed in 10.0.19044.2846
- Microsoft Windows 10: before 10.0.19045.2846 — fixed in 10.0.19045.2846
- Microsoft Windows 11 21H2: before 10.0.22000.1817 — fixed in 10.0.22000.1817
- Microsoft Windows 11: before 10.0.22621.1555 — fixed in 10.0.22621.1555
- Microsoft Windows Server 2012: r2
- Microsoft Windows Server 2016: all versions
- Microsoft Windows Server 2019: all versions
- Microsoft Windows Server 2022: all versions
How to fix
Upgrade to a fixed version: Microsoft Windows 10 Version 1507 10.0.10240.19869; Microsoft Windows 10 1607 10.0.14393.5850; Microsoft Windows 10 10.0.17763.4252; Microsoft Windows 10 20H2 10.0.19042.2846; Microsoft Windows 10 10.0.19044.2846; Microsoft Windows 10 10.0.19045.2846; Microsoft Windows 11 21H2 10.0.22000.1817; Microsoft Windows 11 10.0.22621.1555. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-24924
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-24924
Get alerted when CVE-2023-24924 or the next vulnerability affects your stack